aboutsummaryrefslogtreecommitdiff
path: root/src/kconfig_compiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/kconfig_compiler/CMakeLists.txt')
-rw-r--r--src/kconfig_compiler/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/kconfig_compiler/CMakeLists.txt b/src/kconfig_compiler/CMakeLists.txt
new file mode 100644
index 00000000..31726df1
--- /dev/null
+++ b/src/kconfig_compiler/CMakeLists.txt
@@ -0,0 +1,15 @@
+
+
+set(kconfig_compiler_SRCS kconfig_compiler.cpp)
+
+
+add_executable(kconfig_compiler ${kconfig_compiler_SRCS})
+add_executable(KF5::kconfig_compiler ALIAS kconfig_compiler)
+
+find_package(Qt5Xml 5.2.0 REQUIRED NO_MODULE)
+
+target_link_libraries(kconfig_compiler Qt5::Xml)
+
+# "export" this target too so we can use the LOCATION property of the imported target in
+# FindKDE4Internal.cmake to get the full path to the installed executable instead of using FIND_PROGRAM(), Alex
+install(TARGETS kconfig_compiler EXPORT KF5ConfigTargets ${INSTALL_TARGETS_DEFAULT_ARGS} )