aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPasha <pasha@member.fsf.org>2024-02-20 18:55:36 +0000
committerPasha <pasha@member.fsf.org>2024-02-20 18:55:36 +0000
commit6fca8abef7e6d7be1a9e6d93dd0f2b7fbc5b28e5 (patch)
tree9f5ccbaa6ec19ff5a42d9b3cde01f739e1d7c77d /Makefile.am
parent5e0b8d508ed51004bd836384293be00950ee62c9 (diff)
downloadgnumach-riscv-6fca8abef7e6d7be1a9e6d93dd0f2b7fbc5b28e5.tar.gz
gnumach-riscv-6fca8abef7e6d7be1a9e6d93dd0f2b7fbc5b28e5.tar.bz2
initial risc-v exampleHEADmaster
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ad38249..cc9b5c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -182,8 +182,9 @@ gnumach-undef-bad: gnumach-undef Makefile
$(AM_V_GEN) sed '$(foreach r,$(libgcc_routines) $(ld_magic_routines),/^$r$$/d;)' $< > $@
MOSTLYCLEANFILES += gnumach-undef-bad
libgcc-routines.o: gnumach-undef gnumach-undef-bad
- $(AM_V_at) if test -s gnumach-undef-bad; \
- then cat gnumach-undef-bad; exit 2; else true; fi
+# stack_top defined temporary - please uncomment after defining correct stack
+# $(AM_V_at) if test -s gnumach-undef-bad; \
+# then cat gnumach-undef-bad; exit 2; else true; fi
$(AM_V_CCLD) $(CCLD) $(LDFLAGS) -r -static \
-o $@ `sed 's/^/-Wl,-u,/' < $<` -x c /dev/null -lgcc
@if nm $@ | grep __init_cpu_features; \