aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69f75cf..10920b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,11 @@ case $host_platform:$host_cpu in
host_platform=at;;
default:x86_64)]
[host_platform=at;;
+ default:riscv32)]
+ [host_platform=riscv32;;
+ default:riscv64)]
+ CFLAGS="$CFLAGS -march=rv64gcv"
+ [host_platform=riscv64;;
at:i?86 | xen:i?86 | at:x86_64 | xen:x86_64)
:;;
*)]
@@ -76,6 +81,8 @@ AC_SUBST([host_platform])
case $host_cpu in
i?86)
systype=i386;;
+ riscv*)
+ systype=riscv;;
*)
systype=$host_cpu;;
esac]
@@ -173,6 +180,9 @@ m4_include([i386/configfrag.ac])
# x86_64
m4_include([x86_64/configfrag.ac])
+# riscv
+m4_include([riscv/configfrag.ac])
+
# General options.
m4_include([configfrag.ac])