aboutsummaryrefslogtreecommitdiff
path: root/autotests/kconfig_compiler/CMakeLists.txt
diff options
context:
space:
mode:
authorMontel Laurent <montel@kde.org>2015-03-09 21:55:24 +0100
committerMontel Laurent <montel@kde.org>2015-03-17 07:30:46 +0100
commit094c91f86baf1e82e55b435c07c5ba37ff107dd9 (patch)
treea69172e9f391f2af5114f17b1d091201b3488457 /autotests/kconfig_compiler/CMakeLists.txt
parent270b5ef5abd5b0db5670ffb4473a161e0553e396 (diff)
downloadkconfig-094c91f86baf1e82e55b435c07c5ba37ff107dd9.tar.gz
kconfig-094c91f86baf1e82e55b435c07c5ba37ff107dd9.tar.bz2
Allow to generate qloggingcategories support.
Add new variable to specify it in *.kcfgc : "CategoryLoggingName" CHANGELOG: Allow to generate file with qloggingcategories support. REVIEW: 122931
Diffstat (limited to 'autotests/kconfig_compiler/CMakeLists.txt')
-rw-r--r--autotests/kconfig_compiler/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/autotests/kconfig_compiler/CMakeLists.txt b/autotests/kconfig_compiler/CMakeLists.txt
index 73e89bd2..0cca6052 100644
--- a/autotests/kconfig_compiler/CMakeLists.txt
+++ b/autotests/kconfig_compiler/CMakeLists.txt
@@ -222,6 +222,7 @@ ecm_add_test(${kconfigcompiler_test_signals_SRCS}
LINK_LIBRARIES Qt5::Test KF5::ConfigGui
)
+
########### next target ###############
ecm_add_test(kconfigcompiler_test.cpp
@@ -229,6 +230,16 @@ ecm_add_test(kconfigcompiler_test.cpp
LINK_LIBRARIES Qt5::Test
)
+
+########### next target ###############
+
+set(test_qcategory_SRCS test_qdebugcategorymain.cpp test_qdebugcategory_debug.cpp)
+gen_kcfg_test_source(test_qdebugcategory test_qcategory_SRCS)
+add_executable(test_qdebugcategory ${test_qcategory_SRCS})
+ecm_mark_as_test(test_qdebugcategory)
+target_link_libraries(test_qdebugcategory KF5::ConfigGui)
+
+
########### install files ###############