aboutsummaryrefslogtreecommitdiff
path: root/autotests/kconfig_compiler/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Lohnau <alexander.lohnau@gmx.de>2021-09-14 07:30:32 +0200
committerAlexander Lohnau <alexander.lohnau@gmx.de>2021-09-19 07:50:10 +0200
commit0b0a4464fb3d1145eb612b1ab7edacfa9581c8c9 (patch)
treedb94f2c4daba14f23e13aa65d55a05257f86ab41 /autotests/kconfig_compiler/CMakeLists.txt
parent782750149a0819053d47960fb144f17b7c719d13 (diff)
downloadkconfig-0b0a4464fb3d1145eb612b1ab7edacfa9581c8c9.tar.gz
kconfig-0b0a4464fb3d1145eb612b1ab7edacfa9581c8c9.tar.bz2
Allow KConfigXT to use KSharedConfig::openStateConfig
Otherwise we force consumers to use the config location for state data, which is what we are trying to avoid. Task: https://phabricator.kde.org/T12549
Diffstat (limited to 'autotests/kconfig_compiler/CMakeLists.txt')
-rw-r--r--autotests/kconfig_compiler/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/autotests/kconfig_compiler/CMakeLists.txt b/autotests/kconfig_compiler/CMakeLists.txt
index 2a4b343b..4641c0e0 100644
--- a/autotests/kconfig_compiler/CMakeLists.txt
+++ b/autotests/kconfig_compiler/CMakeLists.txt
@@ -172,6 +172,15 @@ target_link_libraries(test13 KF5::ConfigGui)
########### next target ###############
+set(test_state_config_SRCS test_state_config_main.cpp)
+
+gen_kcfg_test_source(test_state_config test_state_config_SRCS GENERATE_MOC)
+
+ecm_add_test(TEST_NAME test_state_config ${test_state_config_SRCS})
+target_link_libraries(test_state_config KF5::ConfigGui Qt5::Test)
+
+########### next target ###############
+
set(test_emptyentries_SRCS test_emptyentries_main.cpp )
gen_kcfg_test_source(test_emptyentries test_emptyentries_SRCS GENERATE_MOC)