aboutsummaryrefslogtreecommitdiff
path: root/autotests/kconfig_compiler/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedrich W. H. Kossebau <kossebau@kde.org>2019-03-06 13:43:56 +0100
committerFriedrich W. H. Kossebau <kossebau@kde.org>2019-03-15 06:55:13 +0100
commita3ed87ca7808363d8752f919617f88010ebf46b3 (patch)
tree8499bdc6b25490d84e71b4bee3f2be5b159df6f6 /autotests/kconfig_compiler/CMakeLists.txt
parent516f558742dfa8da7a5e6def39309516d703bc1b (diff)
downloadkconfig-a3ed87ca7808363d8752f919617f88010ebf46b3.tar.gz
kconfig-a3ed87ca7808363d8752f919617f88010ebf46b3.tar.bz2
kconfig_compiler: new kcfgc args HeaderExtension & SourceExtension
Summary: When using kconfig_compiler generated sources in projects where the used file extensions for C++ files are not ".h" and/or ".cpp", the include for the generated header looks a bit alien to the project, as well as the generated source file if one looks closer at it. This code adds new optional flags HeaderExtension & SourceExtension which can be used to control the file extensions used for the generated files. Test Plan: All unit tests and the new test_fileextensions pass, existing projects using kcfg without & with the new flags build fine. Reviewers: #frameworks, apol Reviewed By: apol Subscribers: apol, kde-frameworks-devel Tags: #frameworks Differential Revision: https://phabricator.kde.org/D19565
Diffstat (limited to 'autotests/kconfig_compiler/CMakeLists.txt')
-rw-r--r--autotests/kconfig_compiler/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/autotests/kconfig_compiler/CMakeLists.txt b/autotests/kconfig_compiler/CMakeLists.txt
index 590c7700..70b2dbb8 100644
--- a/autotests/kconfig_compiler/CMakeLists.txt
+++ b/autotests/kconfig_compiler/CMakeLists.txt
@@ -241,3 +241,11 @@ gen_kcfg_test_source(test_translation_kde_domain test_translation_kde_domain_SRC
ecm_add_test(TEST_NAME test_translation_kde_domain ${test_translation_kde_domain_SRCS})
target_link_libraries(test_translation_kde_domain KF5::ConfigGui)
+
+########### next target ###############
+
+set(test_fileextensions_SRCS test_fileextensions_main.cxx)
+gen_kcfg_test_source(test_fileextensions test_fileextensions_SRCS)
+
+ecm_add_test(TEST_NAME test_fileextensions ${test_fileextensions_SRCS})
+target_link_libraries(test_fileextensions KF5::ConfigGui)