aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Krause <vkrause@kde.org>2017-07-30 15:47:29 +0200
committerVolker Krause <vkrause@kde.org>2017-08-04 18:54:42 +0200
commitba75a6c6a0231f93fd40480992beec46b0f64885 (patch)
tree9fad6c863da42093d50c8534e3eef969d290b200 /src/CMakeLists.txt
parent48e2e7c9bcd24cc010a6af0a455f8793ea863d40 (diff)
downloadkconfig-ba75a6c6a0231f93fd40480992beec46b0f64885.tar.gz
kconfig-ba75a6c6a0231f93fd40480992beec46b0f64885.tar.bz2
Allow to build KConfig without Qt5Gui
Summary: This is particularly useful for cross-compilation, where we only need the kconfig_compiler on the host system. Reviewers: #frameworks, apol, aacid Reviewed By: aacid Subscribers: aacid Tags: #frameworks Differential Revision: https://phabricator.kde.org/D6994
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 998a1d52..d4ca8869 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,7 @@
add_subdirectory(core)
-add_subdirectory(gui)
+if(TARGET Qt5::Gui)
+ add_subdirectory(gui)
+endif()
add_subdirectory(kconfig_compiler)
add_subdirectory(kconf_update)
add_subdirectory(kreadconfig)